A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2025 - 11:55 CDT
Identified
We have identified an issue with Coach that is preventing calls from being processed. Calls are being imported and recorded properly, but not processed and displayed in the application. We are working to resolve this issue.
Posted Jul 22, 2025 - 10:27 CDT
This incident affected: Coach (formerly ExecVision).