Page Editor Performance Issues

Incident Report for Mediafly

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 11:52 CDT

Monitoring

We reverted to a previous build and expect this to resolve the performance issues. We are continuing to monitor the system.
Posted Jul 31, 2025 - 10:38 CDT

Investigating

Some users are experiencing performance issues using Page Editor. We are investigating.
Posted Jul 31, 2025 - 10:05 CDT
This incident affected: Engagement: Value Platform.