Issues with Third Party Vendor

Incident Report for Mediafly

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 16:08 CDT

Identified

A third party vendor is currently experiencing an outage which is preventing us from being able to process all Google meet calls. We are in contact with the vendor and waiting for the issue to be resolved.
Posted Apr 07, 2025 - 13:49 CDT
This incident affected: Coach (formerly ExecVision).