Engagement Viewer Outage
Incident Report for Mediafly
Resolved
The issue has been resolved.
Posted Oct 31, 2024 - 17:10 CDT
Monitoring
Viewer is back up and we are monitoring it.
Posted Oct 31, 2024 - 16:35 CDT
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Oct 31, 2024 - 16:25 CDT
This incident affected: Engagement: Web Viewer & Devices.