Files failing to open in Document Builder

Incident Report for Mediafly

Resolved

We think the impact from the issue is over.
Posted Mar 26, 2026 - 12:13 CDT

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Mar 25, 2026 - 12:25 CDT