Emails delayed

Incident Report for Mediafly

Resolved

We have identified and resolve the issue that was blocking email delivery.
Posted Feb 25, 2026 - 13:10 CST

Investigating

Our email provider is currently not delivery some emails. We are investigating.
Posted Feb 25, 2026 - 09:49 CST